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Using the Seminar Workbook v2.0 
This spreadsheet application is a simple tool for squadron seminar 
administrators to use to manage student records and record student 
completions to the headquarters database. Coupled with on-line 
registration and its upload feature, it substantially eliminates manual data 
entry both at the squadron level and at headquarters. It also links to a 
Word merge document to print a seminar completion certificate for each 
student. 

The application was developed using Microsoft Excel and Word 2003. 
This updated version is compatible with Office 2007 and the Vista 
operating system. It is a Windows PC application, but it should also work 
on a newer Intel-based MAC with Parallels installed. (See Tips for Office 
2007 users on page 9) 

Installation: 
1. Download and Save the seminarworkbook.zip file to your C:\ drive. 

2. Double-click on seminarworkbook.zip and extract the files to your C:\ 
drive.* This will create a folder named SeminarWorkbook 2.0 
containing the five files used by the application: 

• Seminar_Workbook.xls 
(the main spreadsheet application which contains up to six 
individual seminar worksheets) 

• Registration.txt  (do not rename this file) 
(the holding file for on-line registration e-mail data) 

• Certificate_Merge.doc 
(the merge document for printing certificates) 

• Sample_Preregistration_Email.txt 
(sample e-mail received from on-line registration for practice) 

• Seminar_Workbook_Instructions.pdf 
(this instruction booklet – set printer to print double sided in 
landscape mode) 

 

*  Unless you are an advanced Excel user, be sure to extract the folder 
to the root directory (Local disk C:\), not to any other sub-directory. 

Note: If you have copied the file from a CD and are not running the 
Windows XP operating system, you will need to clear the read-
only attribute from the files. You can do it in one step by right 
clicking on the folder containing the files, select properties, clear 
the box next to the read-only attribute, and click OK. 



2 Seminar Workbook Instructions 

Working with the Seminar Workbook 
The workbook contains separate worksheets for up to six different 
seminars (note the sheet tabs across the bottom initially labeled 
Sheet(1), (2), (3), etc) Each worksheet has been formatted for 100 
students. Adding more than 100 is not recommended as they will not be 
picked up by the automatic print area and sort settings. If the class is 
larger than 100 students, it is recommended that you modify the Seminar 
ID in the Class Assignment Table on the Query sheet and assign the rest 
of the class to another sheet.  

Set up a Class Worksheet 
1. Open the Seminar_Workbook.xls (Excel file). You will get a macro 

warning message. Click ‘Enable Macros’ to activate the toolbar at the 
top of the workbook when it opens. 

2. Select a worksheet, by clicking on its tab at the bottom of the 
workbook. (i.e., Sheet(1), Sheet(2), Sheet(3), etc.) 

3. Fill out the information in the title area – top three rows 

• Squadron Name 
• Seminar Title 
• Location  

Enter the required information in the green shaded cells 

• Seminar date (month/day/year) 
• Seminar code (Inventory #) – an initial list of the first six 

seminars is displayed as you drag your cursor over the cell or you 
can copy and paste it from the list on the CodeList sheet (last tab 
on the bottom of the workbook). 

• Squadron Acct# (four digit squadron account code) 
• Class Number defaults to 1, increment it when two or more of 

the same seminars are held on the same date. 
• District number (01, 16, etc) 

4. You can rename the Sheet() tab to identify it to the class. Right click 
on the tab and select rename. Use any abbreviation meaningful to 
you, but include at least one alpha character. 

example: VHF0306 where ‘VHF’ identifies the seminar and 
‘0306’ it’s date. 

Note: You must also rename the corresponding sheet 
assignment on the Query sheet. (See page 5 ) 
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Warnings: 
As this application was created to be as simple and flexible as possible, 
it also has certain vulnerabilities. None of it is protected, so it can get out 
of whack. Although it can be easily fixed, some specific warnings should 
be heeded: 

1. The cells and column headings that are green are required and 
should not be changed.  

2. Don’t insert, delete or change any of the standard columns as the 
order determines how the data is sent to HQ. You may hide those 
columns you don’t want to see or print and you may add additional 
columns at the end of the rows for your own use. 

Tips: 
1. If you need to remove a student record, select the whole row by 

clicking on the row number (far left) and then right click in the 
highlighted row and select Clear Contents. Running Sort Names and 
Renumber ID from the toolbar will remove the blank line and reset 
the ID numbers. Be sure the first row contains a “1” in the ID column 
before renumbering. 

2. If you wish to sort on any columns other than the automatic 
lastname/firstname provided by the Sort Names button, use the 
standard Excel data sort tool and be sure to highlight the entire 
record area before you choose the column on which you wish to sort. 
Otherwise you could end up with a mess of unrelated data. 

 

Three Steps to Success Pg 
1. Import/record student information .......................... 4 

2. Print Certificates..................................................... 7 

3. Upload student data to HQ .................................... 9 
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Toolbar Buttons 
When you open Seminar_Workbook.xls and Enable Macros, a special 
toolbar is created at the top of the workbook. It contains buttons to 
simplify and automate the principal tasks of the application.  

• Import New Registration – Imports the student information from 
the Registration.txt file containing the data received via e-mail. 

• Sort Names - Sorts the student records on the class sheet in 
Last name/First name order. 

• Renumber ID – Resets the ID numbers in column B. (Be sure 
there is a ‘1’ in the first cell)  

• Setup Merge Names - Creates a list of names on the 
MergeData sheet which is used by the Certificate.doc Word file 
for printing seminar completion certificates. 

• Send Data to HQ – You must be connected to the Internet 
before pressing this button - Creates a text file of the data on 
the current sheet and sends it to Headquarters where it is 
automatically imported into a database on the AS400. 

Importing a New Student Registration 
The Seminar Workbook will import the student registration data received 
via e-mail from the on-line registration process. However, an 
intermediate step is required to copy and paste the data string from the 
e-mail into the “Registration.txt” file. The “Registration.txt” file is reused 
for each subsequent e-mail data string replacing the previous data. 
 
1. Minimize the open Seminar Workbook to place it temporarily on the 

task bar at the bottom of your screen. 

2. Open the “Registration.txt” file. 

3. Open your e-mail containing the prospective student’s pre-
registration data. 

4. Click and drag to highlight the complete data string at the bottom of 
the e-mail.  

 

5. From the Edit menu select Copy  (or press CTRL+C from the 
keyboard)" 
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Tips for Office 2007 users 
Workbook (Excel) 

1. The first time you open the workbook you will see a security 
warning message in the upper left below the main toolbar. Click 
“Options” and enable content under both issues: Macro and Data 
Connection. 

 

 
2. To see the special tool bar buttons, click the ‘Add-Ins’ button on 

the top row of toolbar selections. 

 
 

 
 
Merge Documents (Word) 
 

1. Select ‘Yes’ to continue on the opening message. 

2. Load the ‘Mailings’ toolbar from the top tabs. 

3. After replacing Squadron name, Seminar name and Date on the 
first certificate, click on ‘Finish & Merge’ to see print options. 
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Upload Data to Headquarters 
1. Verify all data for correctness. 

2. Enter a ‘Y’ in the completed column for each student.  

3. Be sure you are connected to the Internet. 

4. Press the Send Data to HQ button from the appropriate class 
sheet. 

a. This process will select all students marked completed 
and create a file named ‘semload.txt’ in the same folder 
as your Seminar_Workbook is located. 

b. An Upload prompt screen will appear. Select the Browse 
button to find and open the semload.txt file. (It will be in 
the same folder as your Excel workbook). The filename 
will fill in on the prompt screen. Click the Send File 
button to complete the upload. 

c. A confirmation message will appear upon successful 
completion of the upload. 

d. The date sent field in the students records will be 
automatically set to prevent them from being sent again. 

e. Any student records that are not marked completed will 
not be sent. 

 

Note: If the upload is not successful (usually the result of not selecting 
the semload.txt file), clear the date sent field in each record before 
trying again. 
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6. Switch to the "Registration.txt" file. 

a. From the Edit menu, click on Select All  to highlight everything 
(or press CTRL+A on the keyboard).  

b. From the Edit menu, select Paste  to replace everything with the 
new data you copied from the e-mail (or press CTRL+V). 

c. From the File menu select Save to save the data in the 
Registration file. (or CTRL+S).  
(Very important step - don't forget to SAVE) 

7. Open the Seminar Workbook file and click on the toolbar button that 
reads Import New Registration. (*See note below)  The student’s 
information will automatically appear on the correct class sheet. 

*Note: The first time a record is imported for a particular class two 
messages will appear informing you that you have to set up the Class 
Assignment table on the Query sheet. 

Set up the Class Assignment Table on the Query 
sheet 
A Seminar ID is automatically generated by the on-line registration 
process based on data contained in the class record listed on the web 
site for which the student wishes to register. That Seminar ID must be 
linked to a specific class sheet in the Workbook. The link only needs to 
be set up once, the first time you import a record for that specific class. 

1. Select the Query sheet tab and you will see the record you imported 
in row 5. 

2. To assign it to a class sheet, select the cell containing the Seminar 
ID (Col A, Row 5) - Copy and Paste into the first available 
Unassigned cell in the Class Assignment Table. This will match that 
Seminar ID to a corresponding worksheet. 

You can rename the individual class worksheets to whatever you 
choose, but make sure that the Seminar ID value in column A of the 
table perfectly matches the Seminar ID that is in the first column of the 
student record and the values in column B exactly match the name on 
the class worksheet tab for that class.  

Once the Class Assignment Table has been set up to link the Seminar ID 
to a class sheet, run Import New Registration again to apply that first 
record to the class sheet. All future imports will automatically apply the 
data from the Registration.txt file to the correct class sheet. 
 
Data can also be entered manually from the Seminar registration forms. 
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Printing the Worksheet 
The following instructions describe automatic printing of the whole 
worksheet in two parts. Two print areas (PrintArea1 and PrintArea2 ) 
have been predefined to allow printing so that both parts will line up and 
can be taped together to show the whole worksheet in reasonably 
readable form.  

1. On the File Menu select Page Setup 

a. Click on the 'Sheet' tab. 

b. In the box labeled Print Area, enter either 'PrintArea1' or 
'PrintArea2'. 

c. Click on the ‘Page’ tab, select Landscape and adjust the scaling 
to 70%. 

2. Click Print Preview to see how it will look. 

Of course, printers vary so you may need to make adjustments 
accordingly. 

PrintArea1 includes Last Name through E-Mail and PrintArea2 includes 
Birth Date through Years Boating. 

If you don’t need to print all the columns and would like to print at 100%, 
you can hide columns you don’t need. Right click in the alpha cell at the 
very top of the column you wish to hide and select Hide. To unhide 
columns, highlight the two columns on either side of the hidden column, 
right click, then click Unhide from the fly out menu.  

Tip: Use the print preview feature to test your settings before sending it 
to the printer. 
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Printing Certificates 
1. Be sure you are displaying the class sheet for which you wish to print 

certificates. Click the Setup MergeNames button to create the list of 
names used by the merge documents. You can look at the data on 
the MergeData sheet to be sure you have set up the right records.  

Note: The MergeData sheet is where the Certificate_Merge.doc looks 
for the names to print on the certificates. You can delete any 
names you don’t want to print. 

2. Minimize the workbook to the task bar to get it out of the way. 

3. Open the Certificate_Merge.doc. 

4. Answer ‘Yes’ to continue the merge on the prompt message that 
appears.  

5. Click on the Tools menu, point to Letters and Mailings and click on 
Show Mail Merge Toolbar, if it is not already showing. 

 
The first time you use the merge documents you will need to customize 
them for your squadron.  

Customize Merge Document 
6. Click on the View Merged Data on the toolbar to display the 

formatted certificate.  

7. Highlight and Replace the Seminar Title, Squadron Name and Date 
on the first certificate. 

8. To display the mail merge toolbar, select View/Toolbars/Mail Merge. 

9. Click on the Mail Merge Recipients icon, click                           and 
select (non-blanks) to prevent blank records from printing. 

10. Click the Propagate Labels icon on the toolbar to bring in the student 
names from the workbook. 

11. Click the Merge to New Document icon and print the certificates. 

12. Close the files without saving them. They will be recreated each time 
you open them. 


