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Running ONCom Windows-based programs on an Apple computer (Rev 2) 
 
General instructions (READ THESE FIRST): 
 
There are several "virtual machine" programs that allow Windows-based programs to 
run on an Apple Macintosh computer, VMware Fusion, Parallels Desktop, and VirtualBox 
are three. Another option is a "dual-boot" system, Boot Camp, which comes with Apple 
computers.  These all require the installation of Windows and a Windows license.  If you 
are using any of these, they should work with all ONCom programs. 
 
At this time we are aware of two options that do not require the installation of Windows 
and a Windows license, CrossOver Mac, and Wine. CrossOver Mac is built on Wine, and 
the annual charge is for support to help you install and run popular applications.  
 
Wine itself is a free open source program that we have successfully used with Celestial 
Tools, PlotTool, Navtra, Visual Passage Planner 2, and The CAPN. Below are install 
instructions for Wine and all the ONCom programs mentioned above. 
 
Download, Install and Configure Wine (Only needs to be done once for ONCom apps.) 
 

Note: When you run Wine or any Windows applications under Wine, any warning messages 
about an application being downloaded from the Internet or being from an unknown or 
unidentified developer must be addressed.  Depending on protection settings and OS release 
this may be handled differently on different Macs. It is often simply a matter of clicking the 
"Open" button.  The procedure for OS X Mountain Lion (10.8) or later for the “’application’ 
can’t be opened because it is from an unidentified developer” case is shown at 
http://osxdaily.com/2012/07/27/app-cant-be-opened-because-it-is-from-an-unidentified-
developer/.  

 
1) Download the latest recommended version of WineBottler 1.7.33 Development or 
later from: http://winebottler.kronenberg.org/ 
 
This is a 140MB DMG file designed to work with Mac OS versions from Snow Leopard 
through Yosemite.  Do NOT download the 1.6.1 Stable version.  (A version of 
WineBottler for Tiger and Leopard is also available.)   
 
When the adf.ly screen appears, watch the countdown in the upper right corner and 
click on "Skip Ads" when the button appears. There is no need to click on anything else 
on the screen 
 
2) Once downloaded, click on the DMG file.  On some browsers a link will be found for 
most recently downloaded files; otherwise look for “WineBottlerCombo_1.7.33.dmg” in 
your downloads folder and click on it - the WineBottler Combo dialog box appears. 
 
3) Drag only “Wine” (the wine glass) into the Applications folder in this dialog box.  

http://osxdaily.com/2012/07/27/app-cant-be-opened-because-it-is-from-an-unidentified-developer/
http://osxdaily.com/2012/07/27/app-cant-be-opened-because-it-is-from-an-unidentified-developer/
http://winebottler.kronenberg.org/
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Although the WineBottlerCombo readme file says to, it is NOT necessary to drag 
Winebottler into Applications. 
 

(Alternatively, Wine.app alone can be downloaded from 
http://winebottler.kronenberg.org/downloads, a 138MB DMG file.)    

 
When the file copying is complete you can close the WineBottler Combo dialog box. At 
this point the DMG file can be deleted if desired. 
 
4) Now open the Applications folder and 
double-click on “Wine”. Either it will 
open, in which case go to step 7, or you 
will get the following dialog box:  
 
If you get this box, just click “OK” to close 
it and follow steps 5 and 6. (See Note 1 at 
bottom of page 4) 
 
 
 
 
5) Control-click on “Wine” in the Applications folder.  
A selection box similar to the one here will come up.  
 
Click on “Open”, the box will then close and Wine 
will now be set to open the next time you double 
click on “Wine”.  (See Note 1 at bottom of page 4) 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
6) Now double-click “Wine” in the Applications 
folder. This time the dialog box shown appears. 

http://winebottler.kronenberg.org/downloads
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Note that “Open” has now been enabled. Click on “Open” and you will get a box like the 
one below, with the registered computer user’s name in place of “Yourname”.  (See 
Note 1 at bottom of page 4) 
  
 
  

 
 
7) Always select the “Run directly in …” radio button. There is no need to change the 
location in the drop down box. When you click “Go” wine will open. If Winebottler was 
dropped into Applications, the “Convert to…” option may be available. Do not select it.  
 

(Once things are working, you can check the "Don't show this dialog again" box, in which 
case this step will be skipped in the future.  If you do this but change your mind, this can 
always be changed in Preferences under the wine glass icon, shown below.) 

 
8) Next, create or verify the Wine prefix, these are the files 
Wine needs to simulate the Windows environment. Click on 
the wine glass icon on the upper menu bar and “File 
System” or “File Manager” from the selection box that 
appears. You may get a message and progress bar saying 
‘Creating “Wine Files”’. If you get a window saying “Prefix 
created successfully” just click “OK”. 

 
 When done a window will come up displaying a file system 
that will look like the image below. 
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Your Wine prefix is now verified. Close any open Wine windows. 
 
9) Click on the wine glass icon on the upper menu bar and “Winetricks” from the 
selection box that appears.  Find and put a check next to "vb6run" and “comdlg32ocx” in 
the "Wine - Winetricks" dialog box and 
click on "Apply". An Install progress bar 
called “Applying Winetricks” will appear. 
  
In the center of your screen, possibly 
hidden under any open windows, another 
window called “Visual Basic 6.0 Runtime 
Redistribution” may appear. Click “yes” to 
complete the Winetricks installation. 
  
When "Winetricks applied successfully" 
appears, click "OK" and close the "Wine - 
Winetricks" dialog box. 
 
Wine is now fully configured. 
 
 
 

 
Note 1:  If after steps 4, 5, or 6, you get no evidence that Wine is working when you click 
on Wine in the Applications folder, look at the Menu bar at the top of the screen. If you 
see a small wine glass, then the application is already loaded. Go to step 8. 
 

 
For those of you who might be interested, icons can be assigned to programs and folders that 
do not get their icons with this process.  To change an item's icon: 
1. Double-click on the image you want to use to replace an existing icon.  It should open in 
Preview, as one or two images. 
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2. If two images, select either one. 
3. From the Edit menu, choose Copy if it is enabled.  If it is not enabled, choose Select All, 
then choose Copy from the Edit menu. 
4. In Finder, Control-click the item you want to have a different icon.   
5. From the File menu, choose Get Info or press Command-I to open the Get Info window. 
6. Click the icon in the upper-left corner of the Get Info window to select it.  It should get a 
blue fringe. 

 
 
7. From the Edit menu, choose Paste or press Command-V to replace the icon. 
A set of icons for VPP2, Celestial Tools, Plottool, and The CAPN can be found here on the 
ONCom site. 

 
 
Program-specific instructions: 
 
Visual Passage Planner 2 (VPP2) 
This program requires a one-time installation before it can be run. 
1) Download the VPP2 setup file, VPP2Setup.exe, from 
www.digwave.com/Download/VPP2Setup.exe.  It should appear in your Downloads 
folder. 
2) Double-click on VPP2Setup.exe. 
3) If your computer is set so the "You are about to open a Wine file" dialog box appears, 
click on “Go”. 
4) Follow the VPP2 setup instructions presented.  In most cases the default selections 
will work.  However, when you reach the "Select Destination Location" dialog box, click 
on "Browse" and select the / drive at the end of the list.  Expand the / drive by clicking 
on the associated plus sign.  Click on Applications, then click OK.  "Z:\Applications\Visual 
Passage Planner 2" should appear in the text box as the destination location.  
5) Continue following the setup instructions until the Setup Wizard is done.  Note that 
no Startup Folder nor desktop icon is created regardless of the selections made during 
the setup. 
 
To run VPP2: 
1) Open the Visual Passage Planner 2 folder in the Applications folder. 
2) Double-click on VPP2.exe. 
3) If your computer is set so the "You are about to open a Wine file" dialog box appears, 
click on “Go”.  VPP2 should open. 

http://www.usps.org/national/eddept/n/files/icons.zip
http://www.usps.org/national/eddept/n/files/icons.zip
http://www.digwave.com/Download/VPP2Setup.exe
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Celestial Tools 
 
 Download the Celestial Tools archive, CelestialToolsnnn.zip (where nnn is the version 
number) from http://www.usps.org/national/eddept/n/tools.htm#celtools. 
 
Some Macs will unzip the file automatically and CelestialToolsnnn.exe will appear in the 
Downloads folder. If not, double-click on CelestialToolsnnn.zip.  Either way, place (drag) 
the unzipped CelestialToolsnnn.exe in the Applications folder. 
 
Double click on CelestialToolsnnn.exe and if your computer is set to get the Wine dialog 
box, make sure the “Run directly in …” radio button is selected, and click on “Go”.  
Celestial Tools should open.  If nothing happens after you click on “Go”, repeat Step 9 in 
the Wine installation instructions on page 4. 
 

 
 

Note: When Celestial Tools is run, the first time any Celestial Tools window is closed it takes 
several seconds after the mouse click for the window to close. After that all of the windows 
open and close quickly.   

 
Navtra 
1) Download the Navtra archive, Navtra13.zip, from 
http://www.usps.org/national/eddept/n/tools.htm#navtra. 
2) Unzip it to your Applications folder.  Some Macs unzip automatically. 
3) In your Applications folder, double-click on navtra.exe.   
4)  If your computer is set so the "You are about to open a Wine file" dialog box appears, 
click on “Go”.  Navtra should open. 
 
Plottool 
1) Download the Plottool archive, plottool20mac.zip. 
2) Unzip it to your Applications folder.  Some Macs unzip automatically. 
3) In your Applications folder, double-click on PLOTTOOL.exe. 
4) If your computer is set so the "You are about to open a Wine file" dialog box appears, 
click on “Go”.  Plottool should open. 
 
 
 
 
 

http://www.usps.org/national/eddept/n/tools.htm#celtools
http://www.usps.org/national/eddept/n/tools.htm#navtra
http://www.usps.org/national/eddept/n/files/plottool20mac.zip
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The CAPN 
 
This program requires installation before it can be run.  It also requires registration and 
the installation of charts. 
 
Program installation: 
1) Follow the setup instructions presented on the yellow sheet provided with the 
program.  In most cases the default selections will work.  The first steps, 1a and 1b, are 
to close all other applications and insert the "THE CAPN SOFTWARE" DVD into your DVD 
drive.  Note that installation will not begin automatically, but a TheCAPN DVD icon will 
appear on the desktop. 
2) Double-click on the TheCAPN DVD desktop icon.  TheCAPN folder should open. 
3) Double-click on Setup.exe. 
4) If your computer is set so the "You are about to open a Wine file" dialog box appears, 
click on “Go”.  The CAPN installation should start. 
5) Follow steps 1c, 1d, and 1e on the yellow sheet.  When you reach the part where you 
are to select the destination folder, click on the Browse button.  A "Select Destination 
Directory" window should open. 
6) At the bottom of the "Select Destination Directory" window, click on the down arrow 
and select z: 
7) When the contents of the z drive appear, double-click on Applications.  The top line 
should now read "Z:\Applications".  Edit this to read "Z:\Applications\Capn Voyager" 
(this may appear automatically), then click OK. 
8) Click Next. 
9) Leave the Program Manager Group as the default, Capn Voyager.  Click Next. 
10) When the Start Installation window appears, click Next.  File installation should 
begin. 
11) When installation is complete, click Finish. 
12) At this point, if you get a Windows Media Player Required message, click Yes and 
follow the next five steps. 
13) When the Windows Media Player 7.1 Setup window appears, click Yes. 
14) Click Yes to the License Agreement. 
15) When the Windows Media Component Setup window appears, click Next. 
16) Check the "I have read the Privacy Statement" check box and click Next. 
17) The next window shows that no components are to be installed.  Just click Cancel, 
then Yes. 
18) The What's New text will now appear.  Read it if you wish, then close the window. 
19) Per Step 1e, click Close Installer.  Do NOT click Install Raster and Vector Charts, plus 
Photo Images. 
20) Open the Capn Voyager folder under Applications. 
21) Change the name of the Wmm.dat file to Wmm.old.  (This and subsequent steps 
make the installation of charts easier.) 
22) Download the latest magnetic variation Wmm.dat file from 
www.thecapn.com/downloads/files/WMM.dat. 

http://www.thecapn.com/downloads/files/WMM.dat


Page 8 of 9 
 

23) Copy the new Wmm.dat file into the Capn Voyager folder. 
24) Program installation is now complete.  Eject the DVD from the drive. 
 
Program Registration: 
Follow the instructions in Section 2 of the yellow sheet, with the following exceptions: 
1) In Step 2a, there is no CAPN Version 8 on the desktop.  Instead, you will find a Capn 
Voyager folder under Applications.  Open it and double-click on 
Capn_Voyager_Mosaic.exe. 
2)   If your computer is set so the "You are about to open a Wine file" dialog box 
appears, click on “Go”.   The CAPN should open. 
3) Follow Steps 2b-2e of the yellow sheet. 
 
Chart DVD Installation: 
Do not follow the instructions in Sections 3 and 4 of the yellow sheet. 
1) Copy the file msdxm.ocx into the Capn Voyager folder. 
2) Create a folder called BSBChart in the Applications folder. 
3) In the Capn Voyager folder (in the Applications folder), double-click on 
Capn_Voyager_Mosaic.exe. 
4) If your computer is set so the "You are about to open a Wine file" dialog box appears, 
click on “Go”.  The CAPN should open. 
5) In the “Review Capn Features” window, select “No Thanks.  I Already Know 
Everything”.  (The “tour” can be accessed at any time from Help>Capn Tour (Sample 
Route, Marks, etc.)) 
6) In the upper menu bar of The CAPN, click on “Charts”, then “Set or Refresh Chart 
Paths”.    The “Specify where your charts are stowed” window should open. 
7) In the lower part of the window, type “z:\Applications\BSBCharts” (without the 
quotation marks).  (Alternatively, in the upper part of the window, work your way to this 
folder by first changing from c: to z: in the top drop-down list.  When done, click on the 
“Add Path” button in the middle of the window.  The folder should appear in the top 
line of the lower part of the window.) 
8) Click on “Save This List”. 
9) if the “Review Capn Features” window appears again, select “No Thanks.  I Already 
Know Everything”. 
10) If the “Select a Route to Display” window appears, select “Close”. 
11) Insert a Chart Region DVD into your optical drive.  (For the N09 course examples, 
homework, cruise, and exam, you will need Chart Regions 111, 117, 120, 124, 125, and 
126.)  When its DVD icon appears on the desktop, double-click it to open it.  You will see 
a folder called BSBChart. 
12) Copy all the files in the BSBChart folder of the DVD into the BSBChart folder you 
created in Applications. 
13) Eject the DVD. 
14) Repeat Steps 11-13 for each Chart Region you need.  
15) In the upper menu bar of The CAPN, click on “Charts”, then “Get a Chart”.  Verify 
that all charts in the BSBChart folder under the Applications folder and in the 

http://www.usps.org/national/eddept/n/files/msdxm.ocx
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AA_Startup_Charts under the Capn Voyager folder are listed.  (If you see charts whose 
first three digits are 113, 114, 132, 184, 185, and 186, you probably have them all.)  If 
you do not have all the charts, reinstall The CAPN using the program installation 
instructions above.  Then check the chart list again.  All charts should be on the list. 
This completes Chart DVD installation. 
 
Running The CAPN: 
Note:  If you have installed the new wmm.dat Magnetic Variation file, you may want to 
go back to the original file in order for the answers to the N09 cruise and exam problem 
to agree with the course.  In the Capn Voyager folder, change the name of wmm.dat to 
wmm.new, and change the name of wmm.old to wmm.dat.  If you get the Magnetic 
Variation warning when starting The CAPN, just click “OK”. 
1) In the Capn Voyager folder, double-click on Capn_Voyager_Mosaic.exe. 
2) If your computer is set so the "You are about to open a Wine file" dialog box appears, 
click on “Go”.  The CAPN should open. 
 


